Results 1 to 9 of 9

Thread: Predator that will just shut off.

  1. #1
    Join Date
    Feb 2016
    Posts
    25

    Predator that will just shut off.

    I have a stock predator (governor disconnected) on a kart my grand daughter autocrosses. We occasionally take the kart to LaFayette Motorsports Park , for practice . Never during an autocross, but every once in a while at LMP the motor will just shut off. By the time I get to the kart I can pull the starter and motor fires right back up and off she goes. Motor has stock gas tank in stock location, kart has 15 deg. mount. I was wondering if anybody else had this problem? Never seem to happen with more than a 1/2 tank of fuel. Is it possible with 15 degree mount the tank will not gravity feed enough fuel. Any ideas?

  2. #2
    Join Date
    Oct 2013
    Location
    Louisiana
    Posts
    481
    It's not venting properly. Drill a small hole all the way through the gas cap. It should solve your problem.

  3. #3
    Join Date
    Feb 2016
    Posts
    25
    Thanks, I will give it a try.

  4. #4
    Join Date
    Oct 2013
    Posts
    153
    Also check for trash in the carb bowl.

  5. #5
    Join Date
    Feb 2016
    Posts
    25
    I will pull float bowl and check.

  6. #6
    Join Date
    Jul 2018
    Location
    Nw ohio
    Posts
    133
    Dumb question but have you disconnected the oil sensor? The oil will move around and cause the sensor to shut motor off then once it settles the sensor will allow you to fire it again.

  7. #7
    Join Date
    Jun 2018
    Location
    Fayetteville, NC
    Posts
    16
    with a 15 degree mount it does move the fuel away from the pick up so you have to make sure you have it full. drill 4 1/8" holes in the gas cap and fill the tank up till you see it in the fill port screen.

  8. #8
    Join Date
    Feb 2016
    Posts
    25
    Quote Originally Posted by Bandmn View Post
    Dumb question but have you disconnected the oil sensor? The oil will move around and cause the sensor to shut motor off then once it settles the sensor will allow you to fire it again.
    Yes ,I have,

  9. #9
    Join Date
    Feb 2016
    Posts
    25
    No junk in float bowl. Drilled holes in gas cap, so far so good. Competed in last weeks autocross , no problems. Going to track Sunday, will see if problem solved. Thanks for responses .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •