Results 1 to 9 of 9

Thread: Help with setup on qrc indoor red dirt

  1. #1
    Join Date
    Nov 2017
    Posts
    21

    Help with setup on qrc indoor red dirt

    Can some one help me with
    Chassis set up.
    I have a a90 qrc we run on red dirt
    In texas. ,was running a green plate
    Clone akra. Kart was loose center
    Off . Added cross but didn't help
    Much. Was at 49 %my son was
    Running flat. Out.

  2. #2
    Join Date
    Oct 2013
    Location
    Kent, Wa.
    Posts
    327
    How much cross did you add, maybe you need lots more? How much is your left side%? You running flat out maybe take a tooth off the axle? The more info you can give the better the answers or advise will be.

  3. #3
    Join Date
    Nov 2017
    Posts
    21
    Added 1% across change from 1 inch to 3/4 inch rear stagger running Burris 11 took one tooth off the rear gear and still lose Center off my son is running flat-footed. should he be letting off going in the corner some . left side 52%

  4. #4
    Join Date
    Oct 2013
    Location
    Marysville, Pa
    Posts
    6,624
    Help me out you say a 90qrc ? Guess I'm trying to confirm is it a standard kart chassis ?

  5. #5
    Join Date
    Nov 2017
    Posts
    21
    2018 winged kart qrc. Model is a 90. Like a box stock winged kart.

  6. #6
    Join Date
    Oct 2013
    Location
    iowa
    Posts
    6,739
    Quote Originally Posted by Jmmarkert View Post
    Added 1% across change from 1 inch to 3/4 inch rear stagger running Burris 11 took one tooth off the rear gear and still lose Center off my son is running flat-footed. should he be letting off going in the corner some . left side 52%
    It turns in good then gets loose? Spin loose or simply slides a bit .
    Are you getting passed in the center of the turn?

  7. #7
    Join Date
    Nov 2017
    Posts
    21
    Spin loose almost . And yes he is getting passed

  8. #8
    Join Date
    Nov 2013
    Location
    Tulsa America
    Posts
    111
    If he's flat footing it sounds like a forward drive issue not a loose issue. Tried more rear%? Think we are running about 54% cross

  9. #9
    Join Date
    Nov 2017
    Posts
    21
    I'll try that thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •